Deprecated: Assigning the return value of new by reference is deprecated in /var/www/web4/web/includes/un_extensions.php on line 910
Svetelektro.com

Svetelektro.com

Meno:
Heslo:
SVETELEKTRO • Problem s USBasp programatorom

Problem s USBasp programatorom

V┼íetko ─Źo sa t├Żka mikropo─Ź├şta─Źov + Sekcia Arduino

Moderátori: psichac, Moderátori

Problem s USBasp programatorom

Odosla┼ąod michal312 » 17 Okt 2020, 18:25

Ahojte, potreboval by som poradit. Zbastlil som si vlastny USBasp programator. Problem je ked ho pripojim k pc pise mi nerozpoznane zariadenie. Firmware je original od Fischl. Poistky takiez by mali byt dobre nastavene. Led svieti cize vyzera ze program bezi v mcu. Skusal som vybrat mcu s patice a tak pripojit k pc a to iste - nerozpoznane zariadenie. Co mi pride divne..
Neviem ci som nespravil chybu pri navrhu ked som zaporny pol s USB spojil s kostrou usb konektora. Moze to ovplyvnit funkciu programatora? lebo nic ine ma nenapada.
Pripajam schemu ako to mam zapojene.
Pr├şlohy
usbasp.PNG
michal312
Obr├ízok pou┼ż├şvate─ża
St├íly ─Źlen
St├íly ─Źlen
Pr├şspevky: 353
Zalo┼żen├Ż: 30.12.2007
Bydlisko: Hlohovec
Karma: 0

Re: Problem s USBasp programatorom

Odosla┼ąod AEdison » 17 Okt 2020, 18:38

N├íjdi ho v spr├ívcu zariaden├ş a po┼íli obr├ízok s podrobnos┼ąami. Mo┼żno nem├í┼í len driver.
AEdison
Obr├ízok pou┼ż├şvate─ża
Zasl├║┼żil├Ż ─Źlen
Zasl├║┼żil├Ż ─Źlen
Pr├şspevky: 1175
Vek: 25.36
Zalo┼żen├Ż: 13.07.2009
Bydlisko: Drienov
Karma: 27

Re: Problem s USBasp programatorom

Odosla┼ąod michal312 » 17 Okt 2020, 18:49

Tu je screen zo spravcu zariadeni. Ale ako som spominal to iste mi vypisuje aj ked mam vybrany mcu s programatora.
Pr├şlohy
dev1.PNG
michal312
Obr├ízok pou┼ż├şvate─ża
St├íly ─Źlen
St├íly ─Źlen
Pr├şspevky: 353
Zalo┼żen├Ż: 30.12.2007
Bydlisko: Hlohovec
Karma: 0

Re: Problem s USBasp programatorom

Odosla┼ąod stefanSK » 17 Okt 2020, 19:05

Ak to m├í┼í zapojen├ę ako na obr├ízku, tak je to dobre.
Probl├ęm m├┤┼że by┼ą:
- zle nastaven├ę poistky- skontrolava┼ą e┼íte raz. Hlavne nastavenie oscil├ítora (extern├Ż kryst.oscilator) a volbu CKlDIV8(nesmie by┼ą nastaven├ę)
- skontolava┼ą, ─Źi je osaden├Ż naozaj 12 MHz kry┼ítal
- ─Źi je nahran├Ż naozaj FW pre verziu s 12NHz kry┼ítalom.
- skontrolava┼ą ozna─Źene pou┼żit├ęho procesora - mus├ş by┼ą ATMEA8-16 nie ATMEGA8L-8 - L-kov├Ż je iba na 8 MHz
Inak ma ni─Ź nenapad├í.

Po zasanut├ş do USB win mus├ş rozpozna┼ą zariadenie, a a┼ż potom in┼ítaluje driver. - vo v├Żpise je VID=0000 - nerozpoznan├ę
Ak by ch├Żbal driver, tak by in┼ítalacia skon─Źila s chybou.
S.K.
stefanSK
Obr├ízok pou┼ż├şvate─ża
Pokro─Źil├Ż ─Źlen
Pokro─Źil├Ż ─Źlen
Pr├şspevky: 660
Vek: 64.92
Zalo┼żen├Ż: 24.06.2010
Bydlisko: Trnava
Karma: 20

Re: Problem s USBasp programatorom

Odosla┼ąod AEdison » 17 Okt 2020, 19:19

Mcu nekomunikuje. Usbasp by sa mal predstavi┼ą ako VID_16C0&PID_05DC. Sk├║s zmeni┼ą R3 na 1k5.

-- Spojen├Ż pr├şspevok 17 Okt 2020, 18:34 --

Teraz pozer├ím ┼że aj m├┤j usbasp m├í R3 ako 2k2. V niektor├Żch sch├ęmach som na┼íiel 1k5, ale pr├ş─Źina to nebude. Zameral by som sa na body ─Źo p├şsal stefan.
AEdison
Obr├ízok pou┼ż├şvate─ża
Zasl├║┼żil├Ż ─Źlen
Zasl├║┼żil├Ż ─Źlen
Pr├şspevky: 1175
Vek: 25.36
Zalo┼żen├Ż: 13.07.2009
Bydlisko: Drienov
Karma: 27

Re: Problem s USBasp programatorom

Odosla┼ąod michal312 » 17 Okt 2020, 20:02

Od rana sa s tym natahujem zapojenie som skontroloval asi milionkrat. Atmegu som pouzil Atmega8 - 16 aj Atmega 8A v datasheete pisu ze je tiez do 16Mhz. Poistky som nastavil FF a C9 pripadne EF-C9. Nahraval som hex od fischl myslim ze ma verziu len s 12Mhz krystalom. Porovnaval som to aj s hotovym programatorom s ciny ktory funguje bez problemov. Vsetky suciastky som niekolko krat pomeral. Plosak som prepipal ci nie je skrat niekde.

Ako tak pozeram zas a znovu na krystal je na nom napisane 12.000x4 moze byt ze je 120Mhz?
michal312
Obr├ízok pou┼ż├şvate─ża
St├íly ─Źlen
St├íly ─Źlen
Pr├şspevky: 353
Zalo┼żen├Ż: 30.12.2007
Bydlisko: Hlohovec
Karma: 0

Re: Problem s USBasp programatorom

Odosla┼ąod stefanSK » 17 Okt 2020, 20:17

Neprehodil si HFUSE a LFUSE?
m├í by┼ą:
# TARGET=atmega8 HFUSE=0xc9 LFUSE=0xef
S.K.
stefanSK
Obr├ízok pou┼ż├şvate─ża
Pokro─Źil├Ż ─Źlen
Pokro─Źil├Ż ─Źlen
Pr├şspevky: 660
Vek: 64.92
Zalo┼żen├Ż: 24.06.2010
Bydlisko: Trnava
Karma: 20

Re: Problem s USBasp programatorom

Odosla┼ąod michal312 » 17 Okt 2020, 20:42

Fuses su OK.Nastavene su presne ako pises vid obrazok. Firmware som nahral tento co je v prilohe.

stefanSK nap├şsal: volbu CKlDIV8(nesmie by┼ą nastaven├ę)

Tuto volbu som nenasiel medzi fuses. Kde sa to nastavuje?
Pr├şlohy
fuses.PNG
fuses.PNG (18.64 KiB) Zobrazená 340 krát
usbasp.atmega8.2011-05-28.hex
(12.94 KiB) Stiahnutá 0 krát
michal312
Obr├ízok pou┼ż├şvate─ża
St├íly ─Źlen
St├íly ─Źlen
Pr├şspevky: 353
Zalo┼żen├Ż: 30.12.2007
Bydlisko: Hlohovec
Karma: 0

Re: Problem s USBasp programatorom

Odosla┼ąod AEdison » 17 Okt 2020, 21:42

Na L m├í by┼ą hodnota 0xEF a zaklikni "Set fuses". CKlDIV8 je jeden z bitov LFUSE.
AEdison
Obr├ízok pou┼ż├şvate─ża
Zasl├║┼żil├Ż ─Źlen
Zasl├║┼żil├Ż ─Źlen
Pr├şspevky: 1175
Vek: 25.36
Zalo┼żen├Ż: 13.07.2009
Bydlisko: Drienov
Karma: 27

Re: Problem s USBasp programatorom

Odosla┼ąod stefanSK » 17 Okt 2020, 22:17

volbu CKlDIV8 m├í ATmega88, to som sa pom├Żlil
S.K.
stefanSK
Obr├ízok pou┼ż├şvate─ża
Pokro─Źil├Ż ─Źlen
Pokro─Źil├Ż ─Źlen
Pr├şspevky: 660
Vek: 64.92
Zalo┼żen├Ż: 24.06.2010
Bydlisko: Trnava
Karma: 20

Re: Problem s USBasp programatorom

Odosla┼ąod michal312 » 17 Okt 2020, 22:31

Trosku som pokrocil. Ked som odpojil obe zenerky od konektora zariadenie bez problemov fungovalo. Po pripojeni diod spat fungovalo len chvilu. Po odpojeni znovu nabehol. Ak som odpojil bud jednu alebo druhu chvilu to islo a potom zas ho windows nerozpoznal.
michal312
Obr├ízok pou┼ż├şvate─ża
St├íly ─Źlen
St├íly ─Źlen
Pr├şspevky: 353
Zalo┼żen├Ż: 30.12.2007
Bydlisko: Hlohovec
Karma: 0

Re: Problem s USBasp programatorom

Odosla┼ąod stefanSK » 17 Okt 2020, 23:03

Daj sem fotografiu ako to m├í┼í zapojen├ę.
S.K.
stefanSK
Obr├ízok pou┼ż├şvate─ża
Pokro─Źil├Ż ─Źlen
Pokro─Źil├Ż ─Źlen
Pr├şspevky: 660
Vek: 64.92
Zalo┼żen├Ż: 24.06.2010
Bydlisko: Trnava
Karma: 20

Re: Problem s USBasp programatorom

Odosla┼ąod V-TWIN » 17 Okt 2020, 23:30

nemaj├║ tam by┼ą n├íhodou zenerky 5V6, v origin├íle s├║ 5V6

https://www.fischl.de/usbasp/
V-TWIN
Okoloid├║ci
Okoloid├║ci
Pr├şspevky: 14
Vek: 64.5
Zalo┼żen├Ż: 18.02.2015
Bydlisko: Bratislava
Karma: 0

Re: Problem s USBasp programatorom

Odosla┼ąod tom666 » 18 Okt 2020, 10:24

michal312 nap├şsal:Trosku som pokrocil. Ked som odpojil obe zenerky od konektora zariadenie bez problemov fungovalo. Po pripojeni diod spat fungovalo len chvilu. Po odpojeni znovu nabehol. Ak som odpojil bud jednu alebo druhu chvilu to islo a potom zas ho windows nerozpoznal.

Pou┼żi 300mW, alebo 500mW zenerky 3V6 - otv├íraj├║ sa 1mA pri cca 3.3V.

V-TWIN nap├şsal:nemaj├║ tam by┼ą n├íhodou zenerky 5V6, v origin├íle s├║ 5V6

V p├┤vodnom zapojen├ş s├║ pou┼żit├ę 3V6 zenerky (500mW, 3.6V - p├║zdro DO-35).
tom666
Obr├ízok pou┼ż├şvate─ża
Zasl├║┼żil├Ż ─Źlen
Zasl├║┼żil├Ż ─Źlen
Pr├şspevky: 1273
Vek: 56.86
Zalo┼żen├Ż: 05.05.2009
Bydlisko: NR
Paragraf: 23
Karma: 43

Re: Problem s USBasp programatorom

Odosla┼ąod V-TWIN » 18 Okt 2020, 10:55

OK, asi som u┼ż slab┼íie pozeral 8O. Ale nem├┤┼że ich ma┼ą zapojen├ę opa─Źne, ke─Ć mu to bez nich funguje?
V-TWIN
Okoloid├║ci
Okoloid├║ci
Pr├şspevky: 14
Vek: 64.5
Zalo┼żen├Ż: 18.02.2015
Bydlisko: Bratislava
Karma: 0

Re: Problem s USBasp programatorom

Odosla┼ąod michal312 » 18 Okt 2020, 11:23

Zobral som novy plosak naspajkoval som tam len usb konektor a taktiez osadil pull up rezistor 2k2 podla schemy cize bez zeneriek a ostatnych veci. Cize na celom pcb je len usb konektor a jeden rezistor. Po pripojeni do usb mi vypisuje nezname zariadenie vlastne to iste ako predtym. To sa mi nejak nezda..

Na scheme je 2k2 osadeny zo spodu(modra farba) priamo pod tym 68 ohm rezistorom
Pr├şlohy
avrpcb1.PNG
michal312
Obr├ízok pou┼ż├şvate─ża
St├íly ─Źlen
St├íly ─Źlen
Pr├şspevky: 353
Zalo┼żen├Ż: 30.12.2007
Bydlisko: Hlohovec
Karma: 0

Re: Problem s USBasp programatorom

Odosla┼ąod tom666 » 18 Okt 2020, 11:38

USBasp pou┼ż├şva V-USB softwarov├║ implement├íciu USB rozhrania.
Popis mo┼żn├ęho rie┼íenia, v├Żhod a probl├ęmov s├║ pop├şsan├ę tu:
http://vusb.wikidot.com/hardware
tom666
Obr├ízok pou┼ż├şvate─ża
Zasl├║┼żil├Ż ─Źlen
Zasl├║┼żil├Ż ─Źlen
Pr├şspevky: 1273
Vek: 56.86
Zalo┼żen├Ż: 05.05.2009
Bydlisko: NR
Paragraf: 23
Karma: 43

Re: Problem s USBasp programatorom

Odosla┼ąod stefanSK » 18 Okt 2020, 12:20

To, ┼że si zapojil pr├ízdny plo┼íak s USB konektorom a pullUp odporom si syst├ęmu iba povedal, nie─Źo sa pripojilo na USB, Low Speed zariadenie. Syst├ęm potom chce komunikova┼ą so zariaden├şm, ale tam ┼żiadne nie je, tak vyp├ş┼íe "nezn├íme zariadenie". Reakcia syt├ęmu je spr├ívna.
Zauj├şmalo by ma:
- hodnota nap├íjacieho nap├Ątia z USB (5V).
- skontrolova┼ą hodnoty odporov - meran├şm, nie pre─Ź├ştan├şm nap├şsanej hodnoty
- ak├ę zenerky s├║ pou┼żit├ę a najlep┼íie by bolo ich premera┼ą (regulovate─żn├Ż zdroj, odpor do s├ęrie so ZD a mera┼ą nap├Ątie na ZD, popr├şpade aj zenerov pr├║d). Samozrejme skontrolova┼ą zapojenie ZD - kat├│da na pin konektora.

M├Ą┼że┼í e┼íte vysk├║┼ía┼ą to, ┼że preru┼í├ş┼í nap├íjanie z USB, zasunie┼í programator do USB a pripoj├ş┼í extern├ę nap├Ątie 5V. Po zasunut├ş by sa ni─Ź nemalo dia┼ą, po pripojen├ş nap├íjania by syst├ęm mal rozpozna┼ą zariadenie.
S.K.
stefanSK
Obr├ízok pou┼ż├şvate─ża
Pokro─Źil├Ż ─Źlen
Pokro─Źil├Ż ─Źlen
Pr├şspevky: 660
Vek: 64.92
Zalo┼żen├Ż: 24.06.2010
Bydlisko: Trnava
Karma: 20

Re: Problem s USBasp programatorom

Odosla┼ąod tom666 » 18 Okt 2020, 12:35

michal312 nap├şsal:... Cize na celom pcb je len usb konektor a jeden rezistor. Po pripojeni do usb mi vypisuje nezname zariadenie vlastne to iste ako predtym. ...

Preco by to malo takto fungovat :?: Potrebuje┼í to kompletne osadi┼ą aj s naprogramovan├Żm MCU :!:
Pre┼ítuduj si pros├şm toto:
https://www.obdev.at/products/vusb/index.html
tom666
Obr├ízok pou┼ż├şvate─ża
Zasl├║┼żil├Ż ─Źlen
Zasl├║┼żil├Ż ─Źlen
Pr├şspevky: 1273
Vek: 56.86
Zalo┼żen├Ż: 05.05.2009
Bydlisko: NR
Paragraf: 23
Karma: 43

Re: Problem s USBasp programatorom

Odosla┼ąod michal312 » 18 Okt 2020, 12:38

Dik za clanok je mi to uz jasnejsie. Zenerky ktore som pouzil boli 1.3W podla toho clanku vyzera to tak ze to moze sposobovat problem. Skusim ich vymenit za 300mW a potom uvidim ako sa to bude spravat. Napatie na usb je 5.12V. Hodnoty odporov som premeriaval merakom medzi pin usb a mcu.

@Tom666 Jasne ze som necakal ze to bude fungovat :D . Len som chcel vediet ci mi pc vypise chybovu hlasku.
michal312
Obr├ízok pou┼ż├şvate─ża
St├íly ─Źlen
St├íly ─Źlen
Pr├şspevky: 353
Zalo┼żen├Ż: 30.12.2007
Bydlisko: Hlohovec
Karma: 0

Ďalšia

Nasp├Ą┼ą na Mikropo─Ź├şta─Źe

Kto je pr├ştomn├Ż

U┼ż├şvatelia prezeraj├║ci si toto f├│rum: ┼Żiadny registrovan├Ż pou┼ż├şvate─ż a 3 host├ş.

Forums ©
Autor str├ínky je Ondrej Z├ívodsk├Ż(zawin), o graficky design sa star├í ─Żubo┼í Fabo(BUFU).

TOPlist

Powered by Copyright © UNITED-NUKE CMS. All Rights Reserved.
─îas potrebn├Ż k spracovaniu str├ínky 0.86 sek├║nd